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Download and installation 

Download 
You can find the downloading links at www.sqview.se . The top link contains all the 
files to run the program, cuesheets, definitions and lists. 

The downloaded file is saved on your hard drive as a zip-file. Extract the files to 
C:\SqView.  
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Installation 
There is no setup or installation file for SqView. Just run SqView.exe. The first time 
the program is started all the paths will be set to the correct location. The user will get 
a question if he/she would like to have a shortcut on the desktop to SqView. 

If you later want to change the paths to the default location go to “File->Restore All 
Paths”. 
 

 

An option menu will be displayed where the user can select how the music files are 
named etc. Read more about this in Options->User Settings. 

 

Upgrade from version 7.x or older 
First make a backup of your music and personal files. The program settings are 
saved in “sqview.ini” and the music settings are saved in “LoopDatabase.txt”. 
 
If you are upgrading from an older version of SqView, download the zip file and 
extract to your SqView folder. Default path is C:\SqView. If Windows ask if the files in 
the SqView folder shall be overwritten select “Yes”.  

 
Run SqView.exe. The program will start with the default settings. To import the 
settings from an older version of SqView go to “File->Import from old version of 
SqView”. 
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In the window that appears select what you want to import: 

 

 
 
Press the “OK” button. After the import is finished restart SqView and you are ready 
to start using the new version. 
 

Reinstall SqView 
First make a backup of the files “sqview.db” and “choreo.db”. These files contain all 
your personal settings and choreography that are saved in the database. 
 
Download the zip file and extract to your SqView folder. Default path is C:\SqView. If 
Windows ask if the files in the SqView folder shall be overwritten select “yes”.  

 
Run SqView.exe. The program will start with the default settings. To import your 
settings again go to “File->Import from SqView Database”. 
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In the window that appears select what you want to import. Select the path to your 
backup copy of “sqview.db”: 

 

 

 

Press the “OK” button. After the import is finished restart SqView and you are ready 
to start using the new version. 

 

If you have saved choreography in the database copy the backup file “choreo.db” to 
the SqView folder. 
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Upgrade the cuesheet 
To upgrade the cuesheets download the “Utility.db” from www.sqview.se. Extract the 
file and copy it to your SqView folder. There are no personal settings saved in 
“Utility.db”.  
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Tab 1 - Music 

 

1. The name shown in the box is the file that is currently selected. To select a song 
double click in one of the list boxes.  

2. Toggle Play/Pause the music. Same as pressing the space bar. 

3. Stop and rewinds the music. 

4. When pressing the button the music will jump 5 seconds backward.  

5. When pressing the button the music will jump 5 seconds forward.  

6. Play the next song in queued list. 

7. Open the lyrics search window. This is explanined in detail in "Tab 2 - Lyrics.". 

8. Shows the lyrics depending on the settings in the options. If no lyric is found the 
button will not be visible. Hot key for lyrics is "T". 

9. This control shows the audio level of the music channels. 

10. List with queued songs. 

11. Show if the next song in the queued list has matching lyrics. Press the button to 
display the lyrics. 

12. Delete the content of the queue list. 

13. Resets all values to the initial values for the file. 

14. Saves the loop start, loop stop, key change, pitch, tempo, speed, eq settings, 
marks, rating and volume to the Loop database. 

15. When this button is pressed default start and stop values for the loop will be set.  
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16. If the box is checked the music will loop between the start value and the stop 
value. If both values are zero the music will not loop even if the box is checked. 

17. Pressing this button will set the loop start value to the current value of the music 
counter. The value is actually recorded when the button is released. 

18. The loop start value. 

19. Pressing this button will set the loop stop value to the current value of the music 
counter. The value is actually recorded when the button is released. 

20. The loop stop value. 

21. Rate value. 

22. Change in pitch on keychange. 

23. Value when the keychange shall be executed. 

24. Shows the music tempo. When a song is selected SqView calculates the BPM 
(beats per minute).  

25. Shows the music pitch. The pitch can be changed up and down in semitones. 
Zero indicates that no change is made. 

26. Shows the music speed. The speed is the same as the recorded sample rate. 
Normal value is 44100Hz. If the speed is changed both the pitch and tempo change.  

27. Shows the music volume. Volume can be set from 0-100%. 

28. The value to the left shows the current position of the music in minutes and 
seconds. The value to the right shows the total length of the music in minutes and 
seconds. 

29. Start a timer for the pause between tips. When the counter is zero a pling can be 
played or the music can start playing. Set the minutes, pling and music start in 
Options->Music->Music->Break Timer. 

30. Show the Square Identification window. 

31. If the box is checked SqView will ask for the name of the dance. All records that 
are selected will be saved with filename, date, time and dance name. All the records 
saved can be viewed in Tools->Track Manager and can be used to select in the song 
lists. 

32. Shows the Markers controls. See View->Music Markers. 

33. If the button is checked the music will start playing after the file is double clicked. 

34. Displays the lyrics for the song when the music is started. 

35. Clock. 

36. Shows how long the music has been playing. It can either count up from zero or 
down from a preset value. When the count is less than zero the figures turn red and 
start to blink. You can toggle up and down counting with hot key "J". The preset value 
is set in Options->Music->Timer. To have the counter in its own window goto View-
>Timer. 
The counter starts when the music starts to play and stops when the next song is 
selected. 
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37. Press this button to select a playlist. All songs on the list will be displayed in the 
list box. 

38. Press this button to select a directory. All songs in the directory will be displayed 
in the list box. 

39. This button will save the songs in the list box to a playlist. You will be prompted 
for a name and where to save it. 

40. When pressed a dialog box will appear. Select what kind of check/search you 
want to perform. The different checks are: Lyrics (displays songs without lyrics), Loop 
database, (songs without loops), Marked, Unmarked, Song title, Track database 
(songs not yet played), Dance name* (songs played at specific dance) and Not 
Dance name* (songs not played at specific dance). The result will be shown in the list 
box. Press reloads to see the whole list again. The last selection is remembered. 

Dance names can be selected from a list of names already used. Parts of dance 
names can be entered to select groups of dances. The current dance is pre-selected. 

41. Reloads the playlist or directory that is selected. The path is shown above the list 
box. 

42. Deletes all the song marks in the list. 

43. Toggle retention of search for lyrics on/off.  If off (Red Bar) you can search for 
and use lyrics, but the search will not be remembered.  This is handy if you want to 
use different lyrics for a song one time.  If the toggle is on, the lyrics searched for will 
be remembered the next time the song is queued, and will show "(L)" in front of the 
song name. 

44. Number of songs in the listbox below. 

45. Shows the path to the selected playlist or directory. When a check or a search is 
done the name of the operation is displayed here. All the paths are saved in the 
combox since the program was last started. 

46. Song list. There are three list boxes. Each can show a playlist or a directory on 
the hard drive. The songs that have been selected are marked with a different color. 
There are a lot of different ways to set up the list boxes; see Options->Music->Listbox 
General and Listbox X. The last selected playlist or directory will appear the next time 
the program is started. Songs can be deleted from the lists with Backspace. The user 
can also drag and drop a song between the listboxes. 

47. The progress bar under the listboxes indicates how much of the file that has been 
played. The user can drag the progress bar to move quickly to another part of the 
song. There are three different progress bars that can be set in Options->Music-
>Music.  

48. Enter a comment for the music. 

49. Fade in/out the music. 

50. Move the selected song one row up in the queued listbox. 

51. Move the selected song one row down in the queued listbox. 
 
52. Delete all songs from the queued listbox. 
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Tracking music  
Some callers like to keep track of the music used during their performances. There 
are several reasons to do this, e.g. to avoid repeated use of the same songs or to 
report the used titles to performance rights organizations (e.g. German GEMA). 

SqView has this ability since the beginning, but functionality has expanded since 
version 7.  

It is now possible to filter the song lists in various ways according to the music used.  

Options 
Callers calling for different groups might want to track each group individually. 
SqView has an option to enter the dance name at each program start. This name is 
remembered and can be selected from a list at the next program starts. The dance 
name can be used to filter the song lists. 

Pre-requisites 
To enable tracking, use the “Tracking” button on the Music tab. 

 

When switched on, it will ask for the dance name. It can be left blank, but it would 
make sense to enter the name of the group calling for.  

If a song was already played with this dance name, the dance name appears in a list 
and can be selected from that list. 

To be asked for the dance name at each program start, the option in Options –> 
Music –> Music –> Track-Name on Start can be set to True 
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Dance names 

 

The dance names for tracking are stored along with the used songs in the tracking 
database. If a song was played (i.e. not only selected) for a specific dance, it appears 
in the tracking database. These dance names appear in a list of the “Trackname” 
window and can be selected either with the mouse or the cursor keys. A new dance 
name can be entered manually. The Dance name field is pre-filled with the last dance 
name used. 

To keep the most used dance names on top of the list, either prefix these with a 
special character (e.g. space, underscore) or prefix seldom used dance names with 
the letter z (or “zz” to make them appear behind “Zebra Dancers”) 

Filtering the song lists 

The song lists in the Music tab can be filtered by several criteria, i.e. only songs with 
that criteria will be displayed. 

One way to use this facility is to avoid repeated use of songs for a group of dancers. 
For this, the lists can be filtered to hide already used songs. This can be done 
manually using the Search button above each list or automatically at program start.  

To switch on the automatic filtering, the option in Options – Music – Music – Listbox 
1/2/3 – “Track filter on start” can be set to True for each listbox. The possibility to do 
this for each listbox individually makes it possible to have one list for hoedowns, 
another one for singing calls, both filtered, and a third one for special music, e.g. 
Friendship Ring, Happy Birthday songs, etc. which is not filtered. 
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The “Track filter on start” uses the last selected filter options, i.e. before this option 
works as desired, each list needs to be filtered manually once. Also remember to set 
the filter criteria back to the desired option if you had used different filter criteria. 

The Reset button will display the full list again.  

Filter options 

 

To hide all already played songs for a dance, use the option “Don’t match the dance 
name in Track Database”. This option displays all the songs that don’t match the 
name of the current dance in the “Find dancename” box. This box is pre-filled with 
the current dance name entered at program start or when enabling tracking with the 
“Tracking” button in the Music tab. It can be overridden manually or selected from the 
“Dancename” list. 

The Checkbox “Match only whole name” is useful if a group is subdivided, e.g. in club 
and class dances. Usually this box is selected, so only the songs for that dance are 
affected. If there will be a combined event for both club and class, only the first 
common part of the name can be entered in the “Find dancename” box and the 
“Match only whole name“ box deselected. This way all the songs used for both parts 
of the group are hidden. 



15 

 

Tab 2 - Lyrics 

 

The lyrics for SqView are stored in a database. The user can select to search for title, 
label or filename. SqView can also search through a directory with lyrics files, same 
as the older versions. Valid format for lyrics are HTM, HTML, PDF and MHT.  
If SqView finds more than one hit during the lyric search the window displayed below 
will be visible. 
  

1. Open the lyrics search window, explained below. 

2. Edit the displayed file. 

3. Save the cuesheet as a file on your harddrive. 

4. The cuesheet. 

The naming convention for the lyrics in the database is "label - title" 

There are three different ways to show lyrics: 
1. In the music tab after pressing "T". 
2. In a separate window. 
3. In lyrics tab (this). 

All the options are found in Options->Lyrics. 
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Lyrics Search Window 

 

 1. Search string for label. 

2. Search for lyrics for title. 

3. Search for label. 

4. Reset the textboxes. 

5. Display the lyrics selected from the list below. 

6. Search for title. 

7. Marry the music to the selected cuesheet. 

8. Select where the lyrics shall be displayed. 

9. Select if SqView shall search through the database or a directory. 

10. List with matched lyrics. 

11. Close the window and show the selected cuesheet. 

12. Close the window without showing any lyrics. 
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Tab 3-17 - List / Definitions 
/ Choreography 

 

 

The last 3-17 tabs are used for showing choreography. Valid formats are HTM, 
HTML, PDF, MHT, TXT and RTF. Each tab can either show files from a directory, 
database or a ini-file that is prepared with paths to different files.  
The files can also be viewed in fullscreen (default for screen 3-4 that are showing list 
and definitions), this can be toggled with a hotkey.  

1. The name of the file that is displayed. 

2. The index of the file that is displayed. 

3. Number of files in the directory / database / ini-file. 

4. The name of the selected directory / database / ini-file. 

5. Choreography type. 

6. Decrease the index by 10 and show the new file. If the value is less than zero after 
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the decrease the index will be set to zero. 

7. Decrease the index by 1 and show the new file. If the value is less than zero after 
the decrease the index will be set to zero. 

8. Change the font for RTF and TXT files. 

9. Select a new directory. 

10. Edit the displyed file. 

11. Reload the latest directory / database / ini-file. 

12. Increase the index by 10 and show the new file. If the value is higher than the 
total after the increase the index will be set to the total number. 

13. Increase the index by 1 and show the new file. If the value is higher than the total 
after the increase the index will be set to the total number. 

14. Save the file path for a later review. All files that are saved with the memory 
button can be viewed in Tools->Memory Manager. 

15. Open a file (ini, HTML, RTF, TXT or PDF). 

16. Random selection of the next file to display. 

17. Open choreography from the database. 

18. Shows the current time. 

19. The content of the selected file.. 
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Menu File 

 

File - Import from SqView Database 

 

Import the settings from another SqView database. Select with the checkboxes which 
group of data that shall be imported. Select the database that shall be imported and 
press "OK". 
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File - Import from old version of SqView 

 

Import the settings from an older version of SqView, version 7.xx or earlier. Select 
with the checkboxes which group of data that shall be imported. Select the directory 
with the old installation and press "OK". 

 

File - Restore All Paths 

This function will restore all paths for Callerlab lists and definitions to point to "your 
folder"\ListAndDef\"Level"List.pdf and "your folder"\ListAndDef\"Level"definitions.pdf. 

 

File - Restore Database 

Restore the database to the initial settings. Same as the first time the program was 
started. 
 

File - Remove content from Music Combo 

Removes all the paths from the three combo boxes above the music listboxes. 
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File - Restore Windows Positions 

Restore the default postion of all popup windows. Such as Timers, Karaoke, Square 
ID, Calls, Hotkeys... 

File - Exit 

Exit the program. Same function as clicking on the cross in the upper right corner. 

Menu - Change Program 

 

Change to another program. This will affect all the tabs after the lyrics tab. The user 
can change program while the music is playing. SqView will start with the latest 
selected program. The options for each program can be found in Options-
>Choreography. 
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Menu - Tools 

 

. 

Tools - Music Manager 

 

The song manager lets you edit all the information in the music database. Double 
click on the song that you want to edit. 
  

1. Saves the changed values in the loop database. 

2. Deletes a file from the loop database. 

3. Export the music database to a CSV file. 
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4. Import a CSV file to the music database. 

5. Check that the music in the database exist on the computer. 

6. Play from 5 seconds before the loop. 

7. Total number of files in the loop database. 

8. Path to the selected file. 

9. Comment, shown in the Music tab if Options->Music->Listbox General->Comment 
visible is true. 

10. Markers. 

11. Length of the selected file. 

12. Speed in Samples per Second. 

13. Pitch in % of change from original (can be negative). 

14. Tempo in % of change from original (can be negative). 

15. Volume in %. 

16. Loop start in seconds. 

17. Loop stop in seconds. 

18. Equalizer band 1. 

19. Equalizer band 2. 

20. Equalizer band 3. 

21. Equalizer on/off 

22. Rating. 

23. Pitch in % change with Keychange 

24. Keychange start in seconds. 

25. Flags 

26. All the music in the database 
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Tools - Playlist Manager 

 

Playlists help you organize your records according to how you want to use them. 
Playlist files are small so it's better to have many playlists rather than copying the 
records into multiple directories. 

1. The name of the directory or playlist shown in the list box below. 

2. Number of files in the list box above. 

3. List of all the music in the directory / playlist. 

4. Reloads the list box below. 

5. Select a playlist to be shown in the list box above. 

6. Select a directory to be shown in the list box above. 

7. Searchstring. 

8. Search for files in the list box that matches the searchstring. 

9. Play the selected music in the list box. 

10. Add the selected file(s) from the list box on the left to the list box on the right. 

11. Add Track DB info to the Playlist. 

12. The name of the playlist shown in the list box below. 

13. Number of files in the list box below. 

14. List of all the music in the directory / playlist. 

15. Delete the selected row in the list box above. 
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16. Reset the list box above. 

17. Moves the selected row one position up. 

18. Play the selected music in the listbox. 

17. Opens a playlist and displays it in the list box above. 

18. Saves the content of the list box above in a file. 

19. Moves the selected row one position down. 

20. Copies the files in the Playlist to a directory on your harddrive.  
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Tools - Choreography Manager 

 

The choreography manager helps you manage the choreography. You can make a 
playlist for choreography in the same way as you make a playlist for the music. 
  

1. The name of the directory shown in the list box below. 

2. List of all the music in the directory / playlist. 

3. Reloads the list box above. 

4. Opens the selected file in a separate window. The file can be edited and saved in 
the window. 

5. Select a level from the database and shown it in the list box above. 

6. Select a directory to be shown in the list box 

7. Number of files in the list box. 

8. Search string. 

9. Search for files in the list box that match the search string. 

10. Search for a call in the files in the list box that matches the search string. 

11. Add the selected file(s) from the list box on the left to the list box on the right. 

12. Add all the files with a relative path "SqViewData\M\M_home001.txt" instead of 
an absolute adress "C:\SqView\SqViewData\M\M_home001.txt" 

13. Start the checkers program specified in Options->Music->General->Checkers. 
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14. Write new choreography and save it to a file. 

15. The name of the file shown in the list box below. 

16. List of all the music in the directory / playlist. 

17. Delete the selected row in the list box above. 

18. Reloads the list box above. 

19. Moves the selected row one position up. 

20. Number of files in the list box. 

21. Opens a new file and displays it in the list box above. 

22. Saves the content of the list box in a file. 

23. Moves the selected row one position down. 
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Tools - Memory Manager 

 

The memory manager is used to remember figures that for some reason need to be 
checked after the dance. When the memory button is pressed in one of the 
choreography tabs the path to the figure will be saved in a file.  
  

1. Number of rows in the database. 

2. Show the choreography in the file. You can edit it here before you save the file. 

3. Deletes the selected row in the list. 

4. Start the checkers program specified in Options->Music->General->Checkers. 

5. List with the paths to the choreography files. 

 

 

 



29 

 

 

Tools - Track Manager 

 

The already used songs are displayed with title, date, time, dance name and list. 

The List column represents the number of the song list in the Music tab. If e.g. one 
list is used for singing calls and one for howdowns, this column can be used to sort 
by music type. 

1. Number of rows in the database. 
2. Export the selected lines in a csv file. 
3. Import the selected lines from a csv file. 
4. Deletes the selected line or lines.Use ctrl-Click to mark multiple lines or shift-Click 
to mark end of range. 
5. The content of the Track database.Initial sort is by date and time used, the newest 
entry on top of the list.  

The listing can be sorted by clicking the headers. Multiple clicks on a header reverse 
the sort order. Multi-column sorts can be done by sorting the minor column(s) first, 
e.g. to sort by date and time, first sort the time column, then the date column. To get 
a list of hoedowns used for a specific group, sort by time, date, list and name.  
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To use the sorted list in another program (e.g. for printing), it can be exported to a 
file. Select the needed records, then use the Export button in the track manager 
window. The file save window opens and asks for the location and the file name. 

To select the whole list, use ctrl-A.  

To select a portion of the list, select the first record with the left mouse button, then 
hold the shift key and select the last record with the left mouse button.  

To select several individual records, hold the ctrl key while selecting the record with 
the left mouse button. 

The list is stored as a textfile with the values separated by semicolon and can be 
opened e.g. in MS Excel or MS Works Spreadsheet.  

Records can be deleted from the track database, e.g. if a song was played by 
mistake and not actually used or to remove older records to make the songs re-
appear in a filtered list.  

Before deleting records, it’s recommended to export the list to a file, maybe choosing 
a file name that includes the date. 

Records to be deleted can be selected the same way as described above. 

Other manipulations to the content of the tracking list can be done using external 
programs and then re-importing the modified list. 
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Tools - Marry Music with Lyrics 

 

 
Open a dialog for the user to marry music with lyrics without playing the music. 

1.The name of the directory or playlist shown in the list box below. 

2. List of all the music in the directory / playlist. 

3. Number of files in the listbox above. 

4. Select a playlist to be shown in the listbox above. 

5. Select a directory to be shown in the listbox above. 

6. Marry the selected music to the selected cuesheet and add the marriage to the 
listbox at the bottom of the window. 

7. The name of the playlist shown in the list box below. 

8. List of all the music in the directory / playlist. 

9. Select a directory to be shown in the listbox above. 

10. Open the selected cuesheet in a separate window. 

11. Shows all the cuesheets in the database in the listbox above. 
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12. Number of files in the listbox above. 

13. Number of files in the listbox with marriages. 

14. Delete the selected row in the listbox with marriages. 

15. Export all the marriages to a csv file. 

16. Import all the marriages from a csv file. 

17. List with all the marriages. 
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Tools - Cuesheets 

 

This tool will create cuesheets for the singingcalls. All the fonts and colors are set in 
Options->Lyrics->StyleSheet. 

1. Song label use the naming "label number" 

2. Title of the song. 

3. Caller on the record, CD, Mp3. 

4. Get info from the record database. 

5. Reset all controls. 

6. Figure for Opener. All lines can be changed by the user. The checkbox at the end 
of each line tells the program that this is a lyricline and it will be dispalyed in a 
different color. 

7. Figure for heads and sides. All lines can be changed by the user. The checkbox at 
the end of each line tells the program that this is a lyricline and it will be dispalyed in 
a different color. 

8. Figure for Middle Break. All lines can be changed by the user. The checkbox at the 
end of each line tells the program that this is a lyricline and it will be dispalyed in a 
different color. 

9. Figure for Closer. All lines can be changed by the user. The checkbox at the end of 
each line tells the program that this is a lyricline and it will be dispalyed in a different 
color. 

10. Tag line. All lines can be changed by the user. The checkbox at the end of each 
line tells the program that this is a lyricline and it will be dispalyed in a different color. 
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11. Additional lyrics, to add a new line in the resulting html-file type <br>. All lines can 
be changed by the user. The checkbox at the end of each line tells the program that 
this is a lyricline and it will be dispalyed in a different color. 

12. Select if the cuesheet shall have one or two columns. If two columns is selcted 
the Opener, Middle Break and Closer is displayed in the left column. The figure is 
displayed in the right column. 

13. Save the cuesheet with 7 figures. Opener-figure-figure-middle break-figure-figure-
closer. 

14. View the html-file in a popup window. 

15. Write the cuesheet to the lyric directory. 
16. Copy the Opener to Middle Break or Closer. 

17. Erase the content in the Opener, figure, Middle Break or Closer. 
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Tools - Records Database 

 

This is a database with information about released square dance records. 

1. Search string. 

2. Specify whether you want to search for title, number, company or caller. 

3. Select a record company and see all the records they have released. 

4. Select a caller and see all the records he/she has released. 

5.The number of records in the database. 

6. The number of hits for the search. 

7. The number of record companies in the database. 

8. The number of callers in the database. 

9. Start searching in the database. 

10. This button will reset all controls. 
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Tools - Checkers 

This command will start a program for pushing checkers. This program is not a part 
of SqView. Set the path to the program in Options->Music->General->Checkers. 
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Menu - Options 

. 

Options – User Settings 
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This dialog displays the most common settings for the user. All settings are still 
available in the music and lyrics options also. The dialog will be automatically opened 
when SqView is started for the first time or when the database is restored. 

Music Naming – Select how the files on your hard drive are named. The Label/Title 
needs to be separated by “ – “, if they are not select “Title.xxx”. 

Path Music – Select the default path or the latest selected path. The default path is 
"C:\SqView\MP3". 

Path Lyrics – If you have cuesheets that you want to display, select the folder where 
they are located here. The default path is "C:\SqView\Text".  

Lyrics Search Order – Select if SqView shall search for cuesheet in the database or 
in the folder mentioned above first. 

Lyrics Search – Specified which part of the music name that shall be used for the 
lyrics search.  

Create SqView shortcut on desktop – Creates a shortcut on the desktop. 
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Options - Music 

 

 
The music options window is divided in General and Music. Everything that affects 
more than one tab or the menu functions are changed in General. 

The Music part have the settings for the music tab and is divide in General, Listbox 
General, Listbox 1-3, Timer, Break Timer and Markers. Each of the named part has 
different options to select. 

There are as you can see a lot of different options. Here are some of the most 
common ones: 

Global File Name Format - Select how your music files are named. This is important 
for the lyricsearch. 
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Global Sort - Select the column for sorting. 
Maximize Window on start - SqView with a maximized window. You can after it has 
started resize the window to your preferred size. 
Change to Current Drive - This option is used if SqView is started from an USB 
stick. SqView will check that the current drive letter is and modified all the paths 
according to that. 
Maximize Volume on start - Windows volume to 100% when SqView is started. The 
volume can be changed after start to any level. 
BASS Buffer (msec) -  The size of the playback buffer. If the music is skipping 
increase the value for the buffer. 
Listbox 1-3 ->Type - Select if the music in the listbox is Hoedown, Singingcall or 
both. It´s important for autostart, lyricsearch etc. 
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Options - Lyrics 

 

 
The first part contains all the search paths for lyrics for listbox 1-3, how the lyrics are 
name and that how the lyrics search shall be done. Also the settings for the 
stylesheet are made here. 

There are as you can see  a lot of different options. Here are some of the most 
common ones: 

Path Listbox - The path to the lyrics that shall be used to seach for lyrics. 
Show Lyrics - The lyrics can be displayed in the Lyrics tab, the music tabs lower part 
or a window. 
Search order - The search order can be "Database first, Directory second", 
"Directory first, Database second", "Database only" or "Directory onyl". SqView only 
provides lyrics in a database. The user can not add anything to the database, but 
he/she can make html cuesheets.  
First If Any - SqView will take the first lyrics that fits the search criteria. Normally if 
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more than one lyric fits the criteria the Lyric search window will be displayed. If 
SqView will not find any music match the Lyric search window will not be displayed. 
Cuesheets with only Lyrics - Only the lyrics will be displayed in the cuesheets, no 
figures or calls. 

  

Options - Choreography 

 

 
Set number of choreography tabs for each level. Also the name and font for each tab 
at each level can be changed here. The global settings will work for all levels if there 
is nothing specified for that level. 
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Options - Hotkeys 

 

 
The function for most of the hotkeys in the music window can be changed by the 
user. Select the function that you want in the right column for each key. 
The hotkeys to the right in the window cannot be changed by the user. There are 
more than 60 different hotkeys functions defined. 
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Options - Select Output Device 

 

 
Select the output device for the music. This is only needed if you don´t want to use 
the default output device. All the computers devices that SqView detects will appear 
in the list. 

Options - Fixed BPM 

 

 
Set a fixed BPM for the song. Each listbox have to be enabled separate. 
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Options – Pitch Adjustment 

 

 
The pitch can be adjusted x semi notes higher or lower. Each listbox have to be 
enabled separate. 
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Menu - View 

. 

 

View - Jukebox 

 

This jukebox let´s the user control from which list the music shall continue to play. 

1. Play the next song from listbox 1. 

2. Play the next song from listbox 2. 

3. Play the next song from listbox 3. 
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4. Play the next song from listbox queued tracks. 

5. Disable the jukebox. 

6. Randomly play a song from the selected list. 

7. Play only the first x seconds of each song. 

8. Number of seconds to play when the "Short" button is active. 

9. Play the next song from the selected list. 
 

View - Recording 

 

This window let´s you control the recording function. Don´t forget to connect an extra 
cable from the amplifier to the computers input. 

1. The name of the file where the recorded music is stored. 

2. The length of the recorded music. 

3. A list with all the output devices. 

4. The recording volume. 

5. Select if start/stop of the music also shall start/stop the recording. 

6. Hide this window. The recording is not stopped. 

7. Start recording. 

8. Stop recording. 

9. Pause the recording. 
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10. Play the last recording. 

11. Path to the directory where the recorded files are stored. 

12. Select if the file shall be named with date-time or a name. 

13. The filename if not date-time is selected. 

14. Index added after the filename to make it uniqu3. 
 

View - Music Timer 

 

This window displays how long the music have been playing or how long time it´s left 
until the counter is zero.  
The behavior is set in Options->Music. 
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View - Equalizer 

 

This window displays a 3 band equalizer, master volume and master tempo controls.  

1. Toggle equalizer on/off. 

2. Music bass control. 

3. Music mid control. 

4. Music treble control. 

5. Music master volume 

6. Music master tempo. The changes will be kept even if a new song is selected. 

7. Music master pitch. The changes will be kept even if a new song is selected. 

8. Equalizer on/off for each song. 

9. Saved settings for equalizer. 

10. Save the settings with a new name. 

11. Delete the selected row in the Combo box. 
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View - Music Control 

 

This window let´s you control the music. The buttons size will increase when the 
window size increases. 

1. The name of the song that is playing. 

2. The music will jump 5 seconds backward. 

3. Play the music. Same as pressing the space bar when the music is stopped. 

4. Stop the music. Same as pressing the space bar when the music is playing. 

5. The music will jump 5 seconds forward. 

6. Shows the lyrics. 

7. Fade out the music. 

8. Decrease the tempo of the song 

9. Increase the tempo of the song 
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View – Music Markers 

 
 
The Marker Settings used in SqView are used mainly for Clubs that have not got a 
Live Caller and have to rely on recorded material. Markers can be used to memorize 
certain places in the recordings e.g. square up times etc. 

 
1. This list shows markers for the Current recording. Note:- The Scroll setting is set to 
ensure the current marker stays visible in the list box. I would suggest a setting of 10 
in Options->Music->Music->Markers->Scroll. 

2. The marker elapse timer in black as shown can be used to show the time from the 
last marker that has been danced, in this case 8 seconds. This timer stops when the 
music is paused. 

3. When this button is pressed the counter is reset to the last marker time and the 
player will start to play from there. The next marker is automatically selected when 
the counter time is higher than the marker time. The current marker is highlighted in 
blue as shown in the marker box above left. 

4. When this button is pressed the selected marker is moved to the next highest 
marker time and the counter is reset to that time and the player will start to play from 
there. Note:- If the player is paused you can move up and down through all the 
marker times. 

5. When this button is pressed a new marker will be entered in the list box as shown 
above top, and will be automatically saved if the Automem box is checked. Note:- 
After setting up and saving markers, the next time the recording is played the Lock 
box is automatically checked to prevent further changes. See Marker options settings 
above. 

6. If a marker is selected in the list box by left clicking it, it can then be deleted by 
pressing this button. You can repeat this operation with the other markers. To 
permanently delete markers you will have to save the changes by pressing the floppy 
disc button on the top left of the music window. Note:- A marker can only be deleted if 
the Lock box is unchecked as shown above top. 
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7. This button can be used if there is a sequence of square dance call that doesn’t 
resolve correctly or there is some other problem, then you can set a jump on a 
marker time in the list box at the start of that section. The marker changes to red, and 
the next time the recording is played the counter will jump over that section to the 
next highest marker time and continue playing from there. To remove the jump press 
the button again. The button have the same function as right clicking on the marker. 

8. Save all the settings, same as the save button in the music tab. 
 
9. Add a comment to the marker. 
 
10. Fade in the music when it starts playing. 
 
11. The markers will be automatically saved if Automem box is checked and the Lock 
box is unchecked, 

12. No new markers will be added to the list. 
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View - Square Identification 

 

In this window a name or identification can be entered for each dancer in a square. 
The user can also select the color of their clothes. 

1. Press this button before editing the listboxes, otherwise the letters are interpreted 
as hotkeys. 

2. Hide the window. 

3. Reset all names and change all colors to grey. 

4. Select the color. 

5. Enter a name or identification. 

6. Open a textfile with names. There can be separate files for boys and girls. 
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View - Show Calls 

 

This window displays randomly selected calls at a given time interval. 3 calls will be 
displayed at the same time.  

1. Hide the window. 

2. Toggle the scrolling on/off. 

3. Set the number of seconds between each new call. 

4. Select the source for the calls. The selections are "Database only", "File only" or 
"Both Database & File". 

5. Select a file with calls. 

6. 3 calls are displayed. 
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View - Computer Cards 

 

This window helps you keep track of which tip that is active when computer 
cards are used. 

1. The tip letter. 

2. The tip number. 

3. Hide this window. 
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View - Hotkeys 

 

This window displays the actual hotkey configuration. It will automatically when the 
hotkeys are changed in the Options menu. 
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View - Karaoke 

  
      

 

This window displays karaoke in cdg format. When the window is displayed and a 
mp3 files is started, SqView tries to open the cdg file with the same name as the mp3 
file. 
If the cdg file is found the karaoke lyrics will be displayed, see the picture to the right. 
If no cdg file is found the message to the left is displayed. 
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View - Tags 

 
This window displays the information in the file tag. 

Menu - Help 

 

. 

Help - Contents 

Contents - Will show the help-file (this!). Same as pressing F1. 
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Help - About 

 

  

About SqView - Shows a dialog box with information about version and how to 
contact the programmer. 
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FAQ 

Q: How do I transfer my setting from my old computer to my new computer? 

A: All user settings are stored in the file sqview.db. Choreograhy sequences are 
stored in choreo.db. These files need to be transfered to your new computer. The 
paths to your music files and SqView folder need to be the same on both computers 
for the transfer to work. 

Q: List and Definitions in PDF format are not displayed correct with Windows 
8? 
A: This is a problem with the build in PDS viewer. To solve the problem change from 
PDF to HTML for List and Definitions. Change Option->Music->General->List & 
Definition format to "HTML". Make sure that the folder "ListAndDefHtml" is located in 
your "SqView" folder. The html files can be downloaded from the SqView website. 

Q: Do I loose my personal settings when I install the latest version of SqView? 
A: You can read here how up upgrade to the latest version without loosing your 
settings. Link to pdf. 

Q: Can SqView run on a Mac? 
A: SqView is a PC-program, but Apple have a solution that is called Boot-
Camp to run PC-programs also. That will give the user a choice of which 
operating system to start when the computer is turned on. You can also run a 

Virtual machine with parallel desktops and have both operating systems started. 

Q: What is new in the latest version of SqView? 
A: You can find the release notes in the helpfile of SqView. 

Q: How is easiest way to get started? 
1. Press the  button above one of the list boxes. 
2. Select the directory where you have the MP3s. 
3. You should now see the MP3s in the list box below the button. 
4. Double click on the song you want to play. 
5. The program searches for the lyrics in the database. If it finds lyrics to the song an 

icon will be displayed below the music title in the upper left corner 
6. To start playing Press SPACE or the green play-button in the upper-left corner. 
7. You can change Pitch and Tempo in real time. 
8. If you want to see the lyrics press "T". 

Q: How do I add my own Choreography? 
1. Go to Tools->Choreography Manager and press Choreography 

button . 
2. Write a sequence. 
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3. Press File->Save and write a name for the file and press Save. 
4. Repeat step 2 and 3 until all your sequences are saved. 
5. Close the window.  

6. Press  button and select the directory with your choreography files. 
7. You should now see the files in the left list box. 
8. Double click on the files that you want in your choreography list. It works the same 
way as a playlist for music. 

9. When the choreography list is finished press  button to save the file. 
10. Close the window. 
11. Select the tab you want to display the choreography. 

12. To show the Choreography list press  button and select the list that 
you have made. 

13. To show all the choreography files in a directory, press  button and 
select the directory. 

14. To see another sequence press  or . 

Q: How do I make a playlist? 
1. To make a playlist go to Tools->Playlist Manager. 

2. Select the directory where you have your music files with the  button 
under the list box to your left.  
3. Select the songs by double clicking on them or mark the song and press the Add-
button. The song will appear in the list box to your right. 

4. When the list is finished press the  button under the list box to your 
right and save the file on your hard drive. Close the playlist dialog box. 

5. In the Music-window press the  button over one of the list boxes and select 
the playlist that you have saved on your hard drive. 

Q: The helpfile is not displayed in the correct way after download? 
A: This is a known Microsoft problem. Open the folder C:\SqView. Rightclick on the 
file "sqview.chm" and select properties. Press the button "Unblock". 
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Release Notes 
9.21.3 
* New button to clear the content in Cuesheet Manager. 

9.21.2 
* The search window above each lisboxes can filter on rate also. 
* DATE, LABEL & NAME can be used to name recording files. 

9.21.1 
* New function to associate a URL with the music file. 

9.20.1 
* Extra stylesheet for choreography 

9.19.2 
* Fixed hotkeys for Markers. 

9.19.1 
* New option to increase/decrease the volume x%. 
* Main menu, changed Level to Program. 
* Fixed a bug in the edit window when there is only one letter on a line. 
* Change pitch in intervals of 0,5 tones.9.18.3 

9.18.3 
* Fixed a bug for hotkeys when Markers are displayed in the music tab. 

9.18.2 
* Fixed a bug for current drive. 
* Fixed a bug for displaying C4 list and definitions. 
* Changed the font size for Square Identification. 

9.18.1 
* Option to have the old Markers layout or a window with Markers 
* Option to load different music playlists for each level. 
* Option so a playlist loaded in the que lisbox will search for lyrics. 

9.17.5 
* Fixed a bug for opening Marker window. 
 
9.17.4 
* Fixed a bug for closing Marker window. 
* Drag and drop support in the same listbos to rearrange the list. 
* A file/page can be opened at startup in tab 2  
* New version of BASS files. 
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9.17.3 
* Option to open Select output device window on start. 
* New buttons in the Cuesheet manager to copy Opener to Middle break and Closer. 
* Fixed a bug in the Music Manager. 
* Fixed a bug for 7 figure Cuesheet. 

9.17.2 
* Auto update for Select output device window. 
* BASS error 9 and 14 will open the Select output device window. 

9.17.1 
* New version of BASS files. 
* Level name in Options->Choreography is used in option header and View calls. 

9.16.6  
* Bug fix for the Choreography Manager. 

9.16.5 
* Bug fix for writing the call "MIX" to the choreography database. 

9.16.4 
* Remember the position for the About window. 
* Bug fix. 

9.16.3 
* New window for music markers, see View menu. 
* Playlist and choreography manager, add new item to selected row. 
* Option to have 7 figures for the cuesheets. 
* Square Identification separate name files for beaus and belles. 
* Added an extra zero for song length in listboxes. 
* Option to always fade out the music.* Choreography type is dispalyed after the 
name. 
* Square ID, replacing corrupt characters. 

9.16.2 
* Bugfix sorting the listboxes in the Playlist Manager. 
* New hotkey to toggle tab 1 and 2. 

9.16.1 
* Changed the font for show calls 
* New version of BASS files. 

9.15.4 
* Square ID - a selection with " - " will be divide in boy and girl. 

9.15.3 
* New version of BASS files. 
* The option "Change to current drive" will also change the Playlists that are loaded. 
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9.15.2 
* New option to show 2/3 of the BPM when the value is between 180-210 

9.15.1 
* Repositioned buttons in the Marry window. 
* Bug fix for showing database content in Marry Lyrics. 
* Import function for MP3Tags comments to music database. 

9.14.8 
* Resized the Square id window. 
* Add hotkeys to play a music file, same as F8-F9. 

9.14.7 
* Bug fix for Change to current drive. 

9.14.6 
* Bug fix for Play/Pause icon. 

9.14.5 
* New option marks in listboxes can be playlist or directory specific. 

9.14.4 
* New version of BASS files. 

9.14.3 
* New function to import/export the married lyrics. 

9.14.2 
* New function to adjust the pitch for all songs in a listbox. 
* New option for the timer to count down the remaining song length. 
* The comment icon will display a "C" when there is a comment. 
* Bug fix in the search dialog in the music tab. 
* Filter function for tracking by date in the listboxes 

9.14.1 
* Bug fix for saving the size of pausetimer window and lyrics window.9.13.8 

9.13.8 
* New function to restore windows positions for all popups. 

9.13.7 
* New option to set the lowest volume to other values than zero. 

9.13.6 
* The "Type" is displayed correct in the Choreography tabs. 

9.13.5 
* Start/Stop music can be selected as a hotkey. 
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9.13.4 
* Marry Lyrics Window will remember the last used dirctory/database. 

9.13.3 
* Recopiled project to run on Windows XP with Visual Studio 2017. 
* Fixed the path for C4 pdf list and definitions. 

9.13.2 
* Separate Basic and Mainstream List/Definitions. 
* The Show calls window can be maximazed. 
 
9.13.1 
* Converted to Visual Studio 2017. 
* The Trackdatebase is sorted before displayed in the comment field. 
* Fixed a bug with compressed view. 
 
9.12.5 
* Fixed a foxus bug in the Track window. 
* Fixed a bug for delayed singingcalls. 
* Fixed a bug for marking in the listboxes. 
* The headlines are also exported from the Trackmanager and Music manager. 
* Option to display double BPM for song with less BPM than 65. 

9.12.4 
* Fixed a bug when plying a wave file as alert sound. 

9.12.3 
* New option to play a song from the queued list when the breaktimer is zero. 
* Fixed a bug when the queued list was saved to the database. 

9.12.2 
* New option to only show the label abbreviation without the number. 
 
9.12.1 
* Improved the random function for choreography. 
* Fixed a bug when the music and lyrics files are in the same directory. 
* Updated the database for calls. 
* The helpfile can be started from SqView with Windows 10 also. 
* New option to hide the levels in the Track window. 
* New dll files for BASS and SqLite. 
 
9.11.4 
* Improved the random play function. 
* Fixed BPM works only when the measured BPM are between 100-140. 

9.11.3 
* Checkbox instead of an option to delete all from the queued listbox. 
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9.11.2 
* The music listboxes can be sort descending by default. 
 
9.11.1 
* Arrow buttons for the queued songs list. 
* Option to save the content of the queued songs when SqView is closed. 
* Buttons to fade in/out the music. 
* Fixed bug in Edit window for opening all file types. 
* More columns for making cuesheets. 
* Choreography can be saved as HTML in the database. 
* New hotkey to open the choreography edit window. 
* HTML is default for List and Definitions. 
* Fixed a bug in Square identification window. 
 
9.10.5 
* Check that the database table is valid before opening. 
* Bugfix in Options->Choreography->Global. 
* Option to change the font in Markers listbox. 
* The level will change when a Dance name is selected from the Tracking window. 
* Fixed bug for Tracking when the music is restarted. 
* SqView will show the latest Track info in the comment field. 
* Added a delete and open function for the choreography database. 
* Changed the size of the Square Identification Window. 
* import a name list in Square Identification Window. 
 
9.10.4 
* Fixed bug for change to current drive. 
* Added sorting for choreography database call. 

9.10.3 
* Tracking saves the active level also 

 
9.10.2 
* Show the Type in the choreography tabs 
* 2 rows in Square identification window 

9.10.1 
 * Updated BASS dll files. 
 * Update SqLite dll file. 
 * List & Definitions in HTML as default. 
 * Changed the test for the hotkey that jumps back on stop. 
  
 9.9.3 
 * Support for FLAC files. 
 * Fixed a bug in the user interface. 

9.9.2 
 * New option to have the same song marks for all listboxes. 
 * Fixed a bug for the Break Timer. 
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 * The content of the music database can be imported/exported as single files. 
  
 9.9.1 
 * New option to hide the number of files in the listbox. 

9.8.9 
* New hotkey to play the previous song. 
* Remember the Tag windows position. 

9.8.8 
* Bugfix for the Break timer. 
* New option to search thru level directories as default. 

9.8.7 
* New hotkey to load a playlist to the queue music list. 
* New option to have a defined number of loops for the hoedowns. 

9.8.6 
* The Break timer will start at the end of the music also. 

9.8.5 
* Fixed focus problem in Playlist Manager. 

9.8.4 
* Check so the "View" windows will be displayed on the screen, independent of the 
resolution. 
* Show MP3 tags, View->Tags 

9.8.3 
* Music Manager - negative values for equalizer settings. 

9.8.2 
* Drag & drop support for folder in Playlist Manager. 
* New User setting to have a default music folder. 

9.8.1 
* Doubleclick on a row in the Memory manager to edit a figure. 

9.7.4 
 * Bug fix for showing music length in Playlist manager.  
  
 9.7.3 
 * Options->Listbox General->Length visible will show the length in the Playlist 
manager also. 
 * Drag and drop for the listbox on the right in the Playlist manager 
  
 9.7.2 
 * Bug fix for showing music length when the program starts.  
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 9.7.1 
 * New option to set the listbox font for Menu->Tools. 
 * New option to set the music queued list font. 
 * Drag and drop for multipel files in Playlist manager listbox 2. 

9.6.11 
* Bugfix for the Playlist Manager. 
 
9.6.10 
* Play-button for the playlist in the Playlist manager. 
 
9.6.9 
* Added a pling everytime the timer is zero and the option "Reset on zero only" is on. 
* Added Drop files function to the Playlist manager. 
* A shortcut in the taskbar works now. 
 
9.6.8 
* New hotkey for adding a song to the queued list. 
* Change drive works for Play Music (F8 and F9) also now. 
 
9.6.7 
* New hotkey for playing from the middle of the song. 
 
9.6.6 
* Bug fix for saving markers. 
* Bug fix for saving tracking to database. 
* The type is transfer for saving choreography to database. 
 
9.6.5 
* New hotkey for saving the music settings. 
* Bug fix for BASS init. 
 
9.6.4 
* Separate files for each level in the Show Calls window. 
* Bugfix for Trackingfilter. 
 
9.6.3 
* Support for Japanese characters in the "Marry Lyrics" Window. 
 
9.6.2 
* Bug fix for fixed BPM. 
 
9.6.1 
* Bug fix for showing the name of the RTF-files in the choreography tabs. 

9.5.8 
* Option to have Japanese character set.  
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9.5.7 
* Drag and Drop support between the listboxes and sorting in the second listbox in 
the Playlist/Choreography manager. 
* Only one decimal is displayed for the tempo 
* Option to display both the default and adjusted tempo value 
* Moved the focus to the listbox in the Lyrics search window 

9.5.6 
* Sorting listbox in Memory manager 
* Sorting listbox in Choreography manager 
* Edit choreography remembers the filename that is edited  
* Removed the Save question in Edit choreography 
* Option to mark the song after a certain time 
* Option to show the tracking date and time in the comment column 
* Option to filter songs on existing file paths 
* Bugfix for enable comboboxes when the music have stopped 

9.5.5 
* Bugfix for saving Equalizer name 
* Bugfix for enable comboboxes when the music have stopped 
* Bugfix for updating the user interface when autolyrics is on  

9.5.4 
* Added Verdana to fonts in options stylesheet 
* Bugfix for Timer 

9.5.3 
* The program will search for lyrics in subfolders also 
* Check that the file exist before open it in the choreography tabs 
* Moved Fixed BPM to Options->Fixed BPM 
* Fixed BPM can be set for each listbox 
* New option to let the timer run x min even if a new song is selected 
* Master Pitch control in the Equalizer window 

9.5.2 
* Bugfix for Music Manager 

9.5.1 
* Bugfix for stop Timer 

9.4.9 
* Remove the content in the Music combo, See File menu. 
* New button for playing the loop in the Music Manager. 
* Bug fix to enter a float value in the Music Manager. 

9.4.8 
* Bug fix in music tab with non existing directory paths. 
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9.4.7 
* Bug fix in music manager and check database. 

9.4.6 
* Bug fix information från Track database. 
* Bug fix progressbar. 
* Bug fix for updating the user interface. 
* The range for the lyrics scrolling have been increased. 
* Bug fix when the randon button was press and the total was zero. 
* Change delete to removed in the Options menu. 
* New function to have a fixed BPM value on every song. 

9.4.5 
* Fixed bug with always calculate the loop values. 
* Fixat Label/Title bug i Playlist Manager. 
* One option to search thru subdirectories instead of three. 
* Enable/disable combo över listbox. 
* Information from Track database. 

9.4.4 
* New hotkey to start music plus x seconds. 
* Show formating for RTF files. 

9.4.3 
* Bugfix equalizer and Volume. 

9.4.2 
* SQL code for searching in database. 
* Export from Database check contains all data. 

9.4.1 
* Music Database check for invalid paths. 
* New function to have a hotkey to "flag" a song. 
* Equalizer settings for each song. 
* Remember on/off state for equalizer. 
* Save equalizer settings for each dancehall. 
* Invalidate user interface in the music tab. 

 
9.3.8 
 * Bug fix for the import/export function in the Music Manager. 
  
9.3.7 
* Added global options for the choreography tabs. 
 
9.3.6 
* New menu for the lyrics window. 
* Changed the sorting algoritm for the listboxes. 
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9.3.5 
* Check that the file "cuesheet2.css" exist on startup. 
* New option to always have the loopvalues calculated even when the loop is not 
activated. 
* Added a toolbars to the cuesheet edit window. 
 
9.3.4 
* Bug fix. 
 
9.3.3 
* New hotkeys to play from loop start/stop. 
* New option for the music to jump back "x" seconds on stop. 
* The Equalizer settings are displayed as numbers also in the EQ window. 
* Added an option for default path in Options->User Settings 
 
9.3.2 
* All windows that are opened from the Tools-menu are modeless. 
* Hotkey to play the next song from the active list. 
* The Reload-button to the right in the Playlist manager is changed to a Reset-button. 
* CSV import/export in the Music manager. 
* Bug fix when deleting a line in the Playlist/Choreography manager. 
* Bug fix when sorting the listboxes on open. 
* Lyrics search window will always start with the "global" settings. 

9.3.1 
 * CSV import/export from the Track manager. 
 
9.2.8 
 * Markers hotkeys works when the markers are hidden. 
 * Option to set the update time in the Karaoke window. 
 * Bug fix for setting the focus to the listboxes with a hotkey. 
  
9.2.7 
 * Bug fix for remembering the markers auto memory. 
  
 9.2.6 
 * Option to only "pling" on hoedowns. 

9.2.5 
 * Faster update of the karaoke window. 
 * The lyrics search window will always have the global lyrics directory as default. 
  
9.2.4 
 * Bug fix in the lyric window and the break timer. 
  
9.2.3 
* The tooltip is not visible when the control is hidden. 
 * Bug fix in the lyrics window. 
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 * The lyrics are reloaded when the edit window is saving a html document. 
 * New option to always show the music tab when the music stops. 
 * New option to init BASS in mono mode. 
 * Workaround for starting SqView from Windows toolbar. 
 * New button in the music tab for entering a comment. 
 * Bug fix for selecting in the playlist manager on loading a directory. 
  
9.2.2 
 * New option to set number of seconds for fast forward and fast rewind. 
 * Keychange function implemented. 
 * Fixed delete songmarkers in a filtered list. 
 * Searching in the music database is now case-insensitive. 
 * Hotkey "T" works in all tabs. 

9.2.1 
* New function to play and view karaoke files. 
* Play music in the Playlist manager. 
* The database is saved to "sqview.dbtmp" on startup. 
* New option to have pdf or html lists and definitions. Html lists & definitions can be 
downloaded from the website. 
* The lyrics search result is memorized and displayed again when the search window 
is opened.  
 
9.2.0 
* Listbox sorting will use the next column for sorting when two rows are equal. 
 
9.1.8 
* Bug fix for characters that the database can not read. 

9.1.7 
* The lyrics for queued music are remembered. 
* New hotkeys for setting focus to each music listbox. 
* The Enter key will work in the same way as a doubleclick in the music listboxes. 
* The Control + Enter key will work in the same way as a rightclick in the music 
listboxes.  
* Increased the scrolling speed for lyrics with the mouse wheel. 
* Deleted File->Save in the edit dialog. Save to database is only enable when it can 
be selected. 

9.1.6 
* Sqview will adjust the layout for screens with 120Dpi. 
 
9.1.5 
* New window for user settings, see Options->User Settings. 
* The lyrics search will search for label/title on the whole lyrics name. 
* Bug fix for changing progress bar. 
* Bug fix for lyrics scrolling. 
* The window for directory selection is now modal and will not disappear. 
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9.1.4 
* Added a solid blue line after the progressbar thumb. 
* Bug fix when the the listbox search returned zero. 
* Changed the Auto scroll lyrics resolution from seconds to milliseconds. 
* Bug fix for listbox search. 
 
9.1.3 
* Bug fix for pdf documents as lyrics. 
* Bug fix for maximize screen on start. 
 
9.1.2 
* Deleted the option for disable mouse scrolling. 
* Changed to one decimal when the music speed is displayed in percent. 
* Bug fix for markers button on/off. 

9.1.1 
 * Bug fix for the listbox sorting. 
 * Increase the scrolling value for lyrics. 

9.1.0 
* Deleted Options->Lyrics->Full screen. 
* The music listboxes can also be sorted by the Rate column by default. 
* The names in the “Change Level” menu are the same as the level name in the 
chorography options. 
* A search for "" in the lyrics search window will list all the cuesheets in the listbox. 
* The stylesheet file "cuesheet2.css" is saved to all folders with lyrics when the 
options are changed. 
* New save button in the Lyrics tab. 
* The "TAB" hotkey switch the focus between the lyrics window and the main 
window.  
* The "End" button will jump to the end of the lyrics. The "Home" button will jump to 
the top. 
* Bug fix with pdf documents when the level is changed. 
* The color for the digital clock can be changed in Options->Music. 
* There will be a message on startup if the computer has larger font than 96 dpi. 
* New option for the music to disappear when the music have been playing 5 
seconds. 
* Bug fix for mouse scrolling. 
* New option to disable mouse scrolling over the listboxes. 
* New options to change the font weight in the lyrics stylesheet. 

9.0.4 
* Bug fix when saving the songlength to the database. 
 
9.0.3 
* Bug fix for updating after pdf-documents is displayed. 
 
9.0.2 
* Bug fix for displaying pdf-documents as lyrics. 
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* Bug fix for sorting the rate column. 
 
9.0.1 
* Bug fix for the lyrics search window. 

9.0.0 
* New version released. 
 
8.10.13 
* Bug fix for scrolling lyrics with keys. 
 
8.10.12 
* Deleted the global option for header name.  
 
8.10.11 
* Bug fix for the lyrics search window. 
* The default alert sound is included in the exe-file. The user can change the sound 
in the Options.  
* Cuesheet.css will be created at startup. 
 
8.10.10 
* Added information in the About window about database versions. 
* Versions in the Utility database. 
* Delete file naming from the Lyrics Search window. 
* Bug fix when sorting the listboxes. 
* New global options for file format etc, See Options->Music and Options->Lyrics.  
* The progressbar will also turn red on overtime.  

8.10.9 
* The mousewheel will scroll the musiclistboxes when it´s over the listbox. 
* Bugfix in the Tools windows with the filenaming. 
 
8.10.8 
* Bugfix for reloading the listboxes and lyricssearch in the Lyrics tab. 
* The latest lyrics search directory in Lyrics tab is saved. 
 
8.10.7 
* Bugfix in the Trackdatabase filter and for searching in subdirectories. 
* New Option to have all the listbox rows in the same color. 
* New Option to have gridlines in the listboxes again. 
 
8.10.6 
* New window for the lyrics options. 
* New Option to only show the lyrics in the cuesheets from the database. 
 
8.10.5 
* Small notebooks will always start SqView maximized. 
* Faster access to the Utility database. 
* Faster loading of data for listboxes in the Tool windows. 



76 

 

 
8.10.4 
* The breaktime can be adjusted with a control below the button in the music tab. Set 
visible in Options->Music->Music->Breaktimer->Edit Breaktime Visible. 
 
8.10.3 
* SqView will remember if the Timer window was opened and in that case open it 
again at startup. 
 
8.10.2 
* New option to select a file for the "ding" sound. Options->General->Alert sound. 
 
8.10.1 
* Shortcut will be created during setup. 
* Bug fix in Tools->Marry Lyrics.  

8.9.8 
* Drag and drop between the music listboxes and the queued list. 
* Change the database paths to the current drive. Useful if you run the program from 
a stick. 
* Option to compress the music controls for smaller notebooks. 
* The tooltip will display the long file paths.  
* Deleted the link to “Help Definitions” form the Help menu. 
* Bug fix in Tools->Marry Lyrics. 
 
8.9.7 
* Window to show the hotkeys 
* Bug fix in the Tools->Marry Lyrics window when saving a marriage. 
 
8.9.6 
* Option to show the speed in percent instead of frequency. 
* Master tempo slider in the Equalizer window. 
* New version of bassenc.dll and bassmidi.dll. 
* Jumbo music control buttons like 7.xx 
 
8.9.5 
* Option to show the tempo in percent instead of BPM. 
* New folder selector. 
 
8.9.4 
* Loop don´t have to be greater than zero for the loop to work.  
* Tool tips 
* Hotkey for view->Cards 
* Setup functionality 
* Scrolling the cue sheet automatically 
 
8.9.3 
* New option to only show the first lyrics hit and don´t show the lyrics search window 
* Bug fix in the lyric search window 



77 

 

 
8.9.2 
* The database file for choreography is now created if it doesn´t exist. 
* Deleted the Marry dialog options 
* Fixed so the arrow keys works for scrolling in the Lyrics tab 
 
8.9.1 
* New icons. 
* The compare function checks the lyrics both in the database and the directory 
depending on the options. 
* Auto shrink databases. 
* Change progress bar colors 
* Different timer values for each level 
* New window for lyrics search 
* Hotkeys for changing the Break Timer value 
* The mouse wheel works to scroll choreography and lyrics 
* 5 more tabs for choreography 
* Option to reset song marks on startup 
* Toggle function for muting music have been changed to increase/decrease volume 
x% 
* Database for choreography 
* Bug fix for displaying files named “title – label.xxx” in the Playlist manager 
 
8.8.6 
* Bug fixes for the markers timer 
 
8.8.5 
* Added more options for the lyrics search 
* Bug fixes for the markers timer 
 
8.8.4 
* Bug fix for markers 
 
8.8.3 
* Bug fix for markers 
 
8.8.2 
* Bug fix 
 
8.8.1 
* Show Length & comment in the listboxes. Option->Music->Music->Listbox General 
 
8.7.12 
* Bug fixed the lyrics search 
 
8.7.11 
* New button to change font in the choreography tabs 
 
8.7.10 
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* Bug fix for displaying queued lyrics 
 
8.7.9 
* Bug fix for displaying queued lyrics 
 
8.7.8 
* Deleted the Save button in the Recording window 
* The recording path can contain spaces now 
* New version of Lame.exe 
* Delete Default color button from background options 
 
8.7.7 
* Bug fix when displaying the Lyrics window 
* Bug fix for timer when the stop button is pressed 
* Reset music button will set the volume to default volume. 
* Bug fix when pressing the button for queue lyrics and the list is empty 
* New button to enter the filename for recording 
* Recording name and counter are saved between sessions. 
* Message box if the recording path contain spaces. 
 
8.7.6 
* Bug fix when deleting a row in the Music manager 
* Bug fix when hitting the “Enter” key the program was closed 
* The selected rows in the Tracking and Music manager are always highlighted 
* Bug fix when letters were written in the Square ID window 
 
8.7.5 
* Hotkey to display queue lyrics 
* Always show selected row in Tools windows 
* Updated button for Square Identification 
 
8.7.4 
* Bug fix status bar “Loop active” 
 
8.7.3 
* Bug fix for importing old Track database 
* Lyrics is hidden when the music is stopped 
* Lyrics window is used to display lyrics/choreography when edit is disabled 
 
8.7.2 
* Bug fix hotkeys didn´t work on startup before there was a left-click in the window  
* New button in the music tab to open Square Identification window 
* New Edit button in Square Identification window 
* Change the column order for exporting in Track manager 
* Fixed problem to display lyrics in the music tab 
* Stop button will rewind the music, but not restart 
* Moved the position of the digital clock in the choreography tabs. 
* Ctrl-A to "select all" in TrackManager window 
* Fixed a bug in the Marry window for always showing selected lyrics. 
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8.7.1 
* New icons in the music tab. 
* Left click any song from one of the three lists and F7 starts (and stops) playing that 
song. 
 
8.6.5 
* Changed default scrolling distance to 10. 
* SqView will remember if the markers were visible when closed 
* Removed Marker window, replaced by controls in the Music tab 
* Added a Yes/No dialog to the delete button in the Track manager 
* Remove the filter checkbox in the Track name window 
 
8.6.4 
* Export Trackdatabase includes list number also. 
* Fixed a bug for importing an old music database 
 
8.6.3 
* No autoplay when the back/forward button for markers are pressed 
 
8.6.2 
* Bugfixfor lyrics search 
* Button to select directory in the Marry window 
 
8.6.1 
* Autostart options like 7.xx 
* Option to auto adjust the column width and save the width  
* Fix hotkey bug for markers in music tab 
* Playbutton in Jukebox window 
* Sort Tracklist by date first and time second. Change month to a number. 
* Add a separate path option for lyrics for each list box. 
* Different lyrics paths for each level. 
* Option to change the name of the level, example “ABC” 
* Option for 1, 2 or 3 listboxes  
* Import setting from another SqView database 
* Hotkey for toggle volume on/off 
* Option for Autoloop time 
* Option to have a delay time before the singingcall starts 
* Option to have the timer pling at 0.00 
* Divide the option to search in sub directories for each listbox  
* Init the default BASS device if the specific device didn´t init correct 
* Option to set the BASS playback buffer 
* Option for each listbox for filtering at startup instead of the general one. 
* Sort on/off for each listbox (Listbox X->Sort). 
* Add the list number to the tracking records.  
* Updated version of basscd.dll 
* Fade in music when counter is zero 
 
8.5.4 
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* Listboxes are sorted after filtering also 
 
8.5.3 
* Bug fix for displaying directory files in the Marry window 
* Change the name and description for Option->Music->Music->Listbox X->Naming 
* Directories will always be sorted in the music tab 
 
8.5.2 
* Bug fix for pressing the “Home” button for settings. 
* The “Select Directory” window is changed to a modal window 
* Option to search for music in sub directories 
 
8.5.1 
* Computer cards 
* When filtering is selected at program start, it is executed (presumably with the last 
option set), but that is not displayed in the Path dropdown box above the list. 
* Remember Listbox path pull downs across Sqview restarts - with option to clear 
all/single entries 
* Option to set Autostart off on Play From Queued, i.e. Hotkey or the Play Queued 
button should just move the song from queued to current 
* Updated version of basswma.dll 
* Digital clock  
* Right Align Clock 
* New icons again 
* Fixed a bug where filenames with dots where not displayed correct 
* Consecutive searches for Title find only in currently displayed list, i.e. need to reset 
between each search.. 
* The countdown timer can start counting down from the length of the music.  
* The lower part of the listboxes was not visible in small notebooks 
* Deleted the option if the FF, FR and break timer shall be visible 
* Move lyrics on/off for each listbox to be located direct above the listbox (the button 
on the right side above each listbox) 
* Lyrics for Queued Track (there will be [L] in front of the name if the lyrics is found) 
* Reverse the equalizer sliders 
* Option to have the Markers with buttons in the music tab, same as 7.xx 
* Deleted the Play button for queued tracks. Start music from queued tracks with 
doubleclick 
 
8.4.12 
* Lyrics option for search “Directory only” is fixed 
 
8.4.11 
* Change in the Auto Breaktimer function 
 
8.4.10 
* Bug fix in Jukebox function when “Autostart” was activated 
* Wrong icon was displayed when “Rewind don´t start” was used 
* Deleted Right double click, was not working as expected 
* Bug fixed open file in “Show Calls”window 
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* Change the Auto Breaktimer so it will count from X min instead of zero 
 
8.4.9 
* Bug fix lyrics search in the lyrics tab 
* Redraw user interface in the lyrics tab is improved 
 
8.4.8 
* Maximize volume on start 
* Option for default volume 
* Double-right click adds to Queued (same as current single-right click) 
* Options for selecting music file and volume for the Break timer “pling” 
* Main volume control in the equalizer window 
* Music Play button will toggle between Play/Pause 
* Music stop button has the same function as restart 
* Restore all paths from Menu->File, not only definitions and lists 
* Menu->View moved Checkers and Record Database to Tools 
 
8.4.7 
* Remember last position and size for View windows after program restart 
* Fixed a bug when searching for name with “’” in the cuesheet database. 
 
8.4.6 
* Autostart for Breaktimer starts counting on zero and down, without pling and start 
music 
* Fix the “dot” bug in the recording window 
* Volume meter for recording. 
* The Space bar sometimes work as the “Enter” key 
* Change the focus in the “View” windows so the space bar will not press a button 
* "There are bugs with the markers operation in that you can't go up and down 
through the markers without the player coming out of pause and there is a conflict 
between the space bar, each time the space bar is pressed a new marker is added."  
 
8.4.5 
* Fixed a bug when in Tool->Choreography when the ”Add” button was pressed 
* Show a user created file in the calls window 
 
8.4.4 
* The text for the function keys F2-F5 was not displayed correct in the hotkey window 
* The music listboxes are always reloaded when the option window is closed with the 
“OK” button. 
 
8.4.3 
* SqView will remember the last position and size of the lyrics window 
 
8.4.2 
* Bug fix in Option->Music->Music->Listbox3->Type 
 
8.4.1 
* Sound effects on hotkeys (F8, F9).  
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* Change "Output Device" without a restart 
* Select Sound font for midi files. 
* Fixed a bug in “maximize window on startup” 
* Fixed a bug so the Choreography tabs can read html files  
* New icons in music tab 
* Added button for “Fast Forward” and “Fast Reverse”  
* Option if the buttons for “Fast Forward” and “Fast Reverse” shall be visible, default 
FALSE 
* Option if the buttons for “Break Timer” shall be visible, default TRUE 
* Option if the “break Timer” shall be auto started 
 
 
8.3.3 
* Option “Maximize window on startup” 
* Moved button for reset tempo, pith, speed & loop to the frame with the properties. 
New icon also. 
* Break timer 
* Fixed a bug when the Rate was changed in the music tab 
* Changed so the modeless lyrics window will be closed when a song without lyrics is 
started. 
* Option to name the listbox headers 
* Option to change title and label in listboxes 
* Option to sort by any column in listbox  
* Option for lyric stylesheet  
* Search box: when Find Title is selected, the cursor should be in the find textbox 
* Doubleclick on the timer will set it to zero. 
* Fixed SD is opened correct now. 
 
8.3.2 
* Bug fixes for lyrics, counter up/down, import rate, marks after reload 
 
8.3.1 
* Lyrics in database 
* New columns in Music database, Restore the databases again and import 
* Music lisbox colums for label, title, rate(option) 
* Large lisbox for queue tracks instead of a combo  
* Music rating  
* Change the music layout. Tempo, Pitch, speed and volume is moved to the left 
* Search window remember settings for each listbox, new in ini 
* Stop button works like Pause, use Pause icon instead of Stop icon 
Showing lyrics before playing caused browser error (maybe only right after program 
installation?, can't duplicate any more) 
* Options - Hotkeys Text for F1 (Open the ?) 
* Lists and Definitions (Tab 3 and Tab 4) are not displayed 
* Displaying the full path of a song in the status bar hides the dance name (moves it 
out of sight to the right) 
* Typo in Music Manager (Pitch) 
* Double Click in empty area of list box causes an error 
* The "Save" button in Track Manager suggests that changes can be un-done. 
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Suggest to rename it to "Export". 
* Starting music when lyrics are displayed causes lyrics to disappear (lyrics in Music 
Window) 
- Dance Name entry (Tracking) does not allow to use cursor keys any more without 
clicking in the list first 
* Selection button is per listbox, but changing one influences the other. Suggest to 
make selection independent for each listbox. 
* Deleting single instances from Queued Tracks 
* The database I mean for the options in the music frame is the music database and 
the others are the Track database, I will change the text so it´s more clear and 
remember the last selected search option for each listbox. 
 
8.2 
* SQLite database instead of text files for settings, etc. loopdatabase, ini 
* Support for FLAC, AAC, M4A and MP4 files. In addition to MP3, CDA, WAV, MIDI, 
KAR, and WMA. 
* Improved hotkey function.  
* Removed many options.  
* Better resolution for the change of tempo.  
* Selectable background color for all windows.  
* The import function to convert from previous versions of SqView, see the "File" 
menu.  
* All tabs can hide the buttons and display a document in "Full Screen". Default for 
the first two choreography tabs. You can select a hotkey to toggle the function.  
* Markers, Equalizer, Jukebox functions are moved from the music tab to its own 
window. You can find them in the "View" menu.  
* "Show Call" and "Square Identification" is also started from the "View" menu.  
* List boxes are not broken down with a column for the label and one for the record.  
* 3 List boxes for the music instead of 2 
* "Comparison" feature is integrated into the search function  
* All paths to the cuesheets are in the database so that the program should not have 
to search all files each time. Press the button along the right in the "Lyrics" tab to 
reload the database.  
* Each level can have 00-10 tabs to show choreography.  
* You can´t edit directly within a document, press the "edit" button instead. This is to 
solve  
problem with the hotkeys always work.  

8.1 
* First version with Visual Studio 2010.  

7.41  
* Increased the max value for the Bass buffer to 3000. 
 
7.40  
* Bugfix for number of loops. 
 
7.39  
* Change the size for the Option->General window. 
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7.38  
* Bugfix for the lyricsearch. 
 
7.37  
* Added support for M4A files. 
 
7.36  
* Added support for MP4 files. 
* Fixed a bug for displaying rate and comments in the listboxes when a user is logged 
on. 
 
7.35  
* Added an option to set the value the volume shall restore to. 
* Delete a song from the next list will hide the displayed lyrics, this is to prevend a 
"deadlock". 
 
7.34  
* Replaced the Bass.dll files with version 2.4.1. 
* New option to delete only one song from the nextlist. 
* New function to decrease the volume with x%. 
 
7.33  
* Bugfix for Memorylist. 
* Delete thread priority changes. 
 
7.32  
* More time selection for Show Calls. 
 
7.31  
* Change the code to find recording devices, same as in 7.16. 
* Fixed a bug for the timer when the music was restarted. 

7.30  
* Fixed at bugg for the function "Delete used files" and select a random song. 
* Fixed a bugg for sound effects and progressbar. 
 
7.29  
* SqView will index all the cuesheets path for faster seraching for lyrics. 
* The filename will be displayed on top of the file view window. 

7.28  
* New option to check if the path is valid before adding the song when a Playlist is 
opened, Options->Music Listbox->Listbox General->Check path on open Playlist. 
* Fixed a bug for playing markers when the music is stopped. 
* Fixed a bug in cuesheet manager when the html file was written. 
 
7.27  
* New option for Autostart, Options->Music->Autostart. 
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7.26  
* New version of BASS dll files. 
* Added a button in the Playlistmanager to copy all the music from a playlist to a 
directory. 
* New option to only init the song from the "Next" list and not start playing the music, 
Options->Music->Don´t start music on Play from "Next" list. 
* Deleted the option to disable the comma key. 
* Deleted information from Options->Choreography. 
* SqView will change the window size for 1024x600 resolution. 
* Card frame is deleted from music window.  

7.25  
* SqView will search for lyrics when a song is added to the next list. 
* More selections to compare what´s in the Trackdatabase and in the music listboxes. 
* Deleted the "Delete All" button from the Track Manager. 
* Option so the Marry Window can have tile-label instead of label-title.  

7.24  
* Changed the recording function back to version 7.21.  

7.23  
* New function to show random calls on the screen, Tools->Show Calls. 
 
7.22  
* Wrong function were defined for hotkeys "C" and "V" during installation. 
* More recorddevice are found by the program. 
* New function to loop from the songlength to zero. Option->Musix->Loop at end. 
 
7.21  
* The user can select different files that keep track of which songs have been played, 
Options->General->List Colors 
* Hotkey for playing the next song from left/right listbox. 
 
7.20  
* New option for the timer, "Red on Overtime". The timer will be red both on count 
up/down after X minutes. 
 
7.19  
* Fixed a bug with saving the progressbar settings in the Song Manager. 
* The user can select the Hotkeys for each functions. 
* The user can select the output device for the music, Options->Select Output 
Device. 
* New function for the Markers.  
* The Music listboxes can show the length and creation date/time for the file. 
* Deleted support for RA-files, didn´t work with the new version of Winamp. 
* Option to set the default volume. 
* Added a save button to the Recording window so the user can save all the settings.  
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7.18  
* The View-button in the Choreography Manager can show the same format as the 
choreography tabs.  

7.17  
* Extra dialog added when the program is started to select the output device.  

7.16  
* Option to show the lyrics over the controls in tab2. Options-Lyrics->Maximize lyrics 
window.  

7.15  
* More functions for recording. 
 
7.14  
* New BASS files, 2.4. 
* New look on the Tooltip control. 
* Fixed a bugg in the Song Manager. 
 
7.13  
* Function to record your dance. 
* Option to hide the Webcam, Square ID and Recording icon. 
 
7.12  
* Updated randomize function for playing songs. 
* The name of the levels can be changed by the user in Options->Choreography-
>Program->Change. 
* Larger Progressbar with more color. 
* Equalizer On/Off is saved for each file, set Options->Music->Miscellaneous-
>Equalizer On/Off for each song to true. 
* A new dialog for Marrying songs and lyrics, see Options->Lyrics->Marry->Marry 
Music - Lyrics. 
* The Cuesheets manager can make lyrics with both 1 and 2 columns. 
 
7.11  
* Bugfix for importing files in the Song Manager. 
 
7.10  
* New window for showing a directory tree, View->Music Directory Tree. 
 
7.09  
* Added search in subdirectorys in the Playlist Manager. 
* Fixed a bugg in the Lyrics window. 
* Reload the listbox when the option "Remove used music from list" is on and the 
listbox is empty. 
 
7.08  
* Recompiled all files. 
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7.07  
* Rate, Comment 1-2 can be visible in the Playlist Manager, Options->General-
>Playlist Manager. 
* Added Lyrics on/off for the Window Listbox also. 
 
7.06  
* Option to right align the clock in the music tab. 
* Continue mode can play from next-list also. 
* Html-editor for the cuesheets. 
* Better fault message when a file is not found.  

7.05  
* Play/Stop works on both listboxes in the Playlist Manager. 
* Fixed a bug in the progressbar 
* The user can set a path to the Loopdatabase 
* Path to Playlist folder 
* SqView can search for only names in the Loopadabase, independent of folder 
* Show lyrics on Play is available between the listboxes 
 
7.04  
* The user can select Lyrics search on/off in the music tab. 
 
7.03  
* Added more options to the Playlist Manager. Can be found in Options->General. 
* Fixed a bug for deleting used music from the listbox. 
 
7.02  
* Added the same options to the Playlist Manager as the Music listboxes have. Can 
be found in Options->General. 
 
7.01  
* Fixed so F8 and F9 will work when the music is not playing. 
 
7.00  
* More options on restart, see Options->Music. 
* Play a song x minutes and when fade out. 
* The comma hotkey can be disabled. 
* Option to always show the Marry-dialog for lyrics. 
* Relative paths for Plaaylists and Choreographylists. 
* Different users with individual settings for songs. 
* New BASS files. 
* Soundfonts for Midi-files. 
* CDDB information added. 
* New window for Choregraphy, Playlists and Music control (with jumbo buttons). 
* Different progressbars can be selected for each song. 
* Guest caller mode that don´t allow any changes. 
* Deleted CD info. 
* Deleted the CPU load from the music tab.  
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6.72  
* Tempo and pitch can be changed on all MP3-files (no more Tempo 0.0). 
 
6.71  
* Added a hotkey (F11) for showing the hotkey dialog. 
* Fixed a bug for scrolling lyrics. 
 
6.70  
* Added an option to reset the timer when the music was restarted with the ".". 
* Resetbutton for the "Next" list in the current frame. 
* Changed the function for hotkey "'" and "H". 
* Changed the size of the hotkey window. 
* Message to the user if the Loopdatabase are too large. 
* Message to the user if the computer is set on 120 DPI. 
* Added an option to fade in the music when it´s started from the markers list.  

6.69  
* Buggfix for compare lyrics.  

6.68  
* Added an option to have the pling only on hoedowns  

6.67  
* Added a minimize button to the Hotkey dialog. 
 
6.66  
* Added an option if the program shall be maximized on startup. 
* Moved the option for timerupdate and bass buffer to the System dialog. 
* Fixed a bug in the lyric scrolling. 
 
6.65  
* Deleted support for Au, Aif, Voc, Bonk and Iff files. 
* Added an option to show the digital clock again. 
* Added an option to don´t show the MP3-Tag button. 
* Added an option to show the Zero-button again. 
* Updated the support for large fonts. 
* Added a new dialog that shows the system settings, Options->System. 
 
6.64  
* Released version. 
 
6.63  
* Bug fix. 
 
6.62  
* Added an option so the timer will stop counting when the music is stopped. 
 
6.61  
* The user can have different lyrics for the same song depending on the level. 
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* Reload button in the choreography tabs. 
 
6.60  
* The lyrics can scroll automatic, set how often and how much in the options->Lyrics. 
 
6.59  
* All the dialogs under Tools are Modeless. 
* Fixed a bug in the Timer Break. 
* Added support for large fonts. 
 
6.58  
* Change rate to 0-9. 
* The controls will adjust with resizing. 
 
6.57  
* Fix a bug with cuesheets. 
* Option - Don´t search for lyrics can be choosen for left/right listbox. 
* Hotkey "T" is the same as pressing the lyric button in tab 1.  

6.56  
* Fix a bug for playing Midi-files. 
 
6.55  
* New analog clock. 
* Extended the Cuesheet manager with "Middle Break & Closer". 
 
6.54  
* Fixed a bug in the Playlist Manager. 
* Default button for Options. 
* The Right/Left arrow will show the next choreography file in tab 5-11. 
* Added a dialogbox to confirm reset controls. 
 
6.53  
* Label and Title can be switched when searching for lyrics. 
* Option - SqView can be drive independent. 
* Support for printing cue sheets and choreography. 
* Loop-, Track-, Memory- and Eq Database have to be in the same directory as 
SqView. 
* Changed the menu, renamed a few entrys. 
* Cuesheets and Recorddatabase can be updated from Internet, see Help->Update. 
 
6.52  
* Que more than one song to play. 
* Delete some options. 
* Option - Hoedowns always with Autostart and Singingcall without Autostart. 
 
6.51  
* Change Mainstream53 to Basic. 
* Added Maximize/Minimize to the View Cue Sheet window. 
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* Added an empty template for writing Cue Sheets. 
* Option - The music can back x sec when the stop button is pressed. 
 
6.50  
* Added sound effects (F8-F9). 
* Extended the startup of the Webcam dialog.  

6.49  
* Another buggfix.  

6.48  
* Buggfix for showing lyrics. 
 
6.47  
* Fixed some small bugs in Add Choreography. 
 
6.46  
* Changes so Hoedown will search for lyrics also. 
* Reset Controls will also reset next song. 
 
6.45  
* Change the meaning of hotkey X to reset timer. 
* F7 will have the same function as SPACE. 
* Fixed some small bugs. 
 
6.44  
* Added a link to download the latest Recorddatabase 
* Delete the Midi Device selection from Option-General 
* Changed the icon for reset the music controls 
* Option for how the marked songs shall be deleted (one or all) 
* New Setup program with more options 
 
6.43  
* Helpdefinitions is updated 
* Html definitions are updated and included in the download 
* Easy wizard to make Cuesheets 
* Marry Lyrics to any music  
* Buggfix for the Equalizer 
* Backup - Import 
* Open the help from all dialogs 
* Option to don´t search for lyrics 
* Hoedown will never search for lyrics 
* Fixed the bug that didn´t allow SD to be in another directory 
* Choice to only delete the mark for one row in the listbox 
* Larger font in the Square ID dialog 
* Timer for pause between tips 
* Option to have a "pling" when the timers are zero  
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6.42 
* Format choreography before adding it 
* Choose your own font and size for the listboxes 
* Option - Left click once same as right click 
* Checker on the level that is selected 
* Backup - Export  

6.41 
* Hotkeys for levels F2-F5 
* Updated GUI 
* Progressbar for music larger and always showed 
* Added combobox over the listboxes for fastselection of the opened lists/dirs 
* Edit MP3 tag 
* New icon for save 
* Buggfix for the lyricswindow 
* Changed Mark to Markers 
* Tool tips 
* Rightclick will remember if the song was a hoedown or singingcall 
* Option - Full volym and no muting on startup 
* Hotkey F6 for changing the lyricview 
* Statusbar that will show a progressbar for the music, tempo and loop/play status. 
* Option - Remove the used music from the list. 
* Added hotkeys for the volume. 
* Change the meaning of hotkey B, N, Z and <. 
 
6.40 
* Buggfix for showing marked files after restarting the program. 
* Updated the Hotkey window.  

6.39 
* Support for a webcamera to take a snapshot of the pilotsquare. 
* Pressing "T" in tab 2 will make a jump to tab 1. 
* Change the meaning of hotkey U, I and §. 
* Option to always show the lyrics when the music is started. 
* Updated the user interface. 
 
6.38 
* Change the textsize, fontname and color of the stylesheet for lyrics. 
* Change the color of the text in the listboxes in the music tab. 
* Choreography can be marked as used. The user can choice not to show used 
choreography. 
* PageUp/Down and Arrow Up/Down will scroll the lyrics or choreography. 
* Q & W will change to the last used playlist or Directory in the music Tab.  

6.37 
* Plugin for playing textfiles removed. 
 
6.36 
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* Added the choice to open a list in the left listbox in Playlist Manager. 
* Shows the name of the song that is playing in the Playlist Manager.  

6.35 
* Added the same buffert for the music in the Song Manager as in the Music tab. 
* Removed the pitchshifter. 
* Removed options for showing Bass error  

6.34 
* Added a choice so the latest selected list or dir is not saved. 
 
6.33 
* Fixed bug when the listboxes was saved in the Music Tab 
* Fixed bug that Marks are deleted when a list is saved in the Music Tab 
 
6.32 
* Play more formats MP3, MP2, MP1, WAV, OGG, CDA, WMA, MID, KAR, VOC, 
AIF, IFF, BONK & AU 
* Choreography and Lyrics can be in TXT, PDF, RTF, HTML and MHT format 
* Font name, font size, bold and italic are saved for each tab 
* A button with the same function as"." 
* Rating can be set in the music tab 
* Delete more than one entry in the Songmanager 
* Edit Marks in the Songmanager 
* Edit and Save playlist in Music Tab 
* Improved the searchfunction in the Music Tab 
* If Length and type are selected the whole time for the list will be showed 
* When lyrics for a song is showed in the Lyrics Tab, a Playbutton will be showed if 
there is a song with the same name 
* Select id the Save button in Tab 5-11 shall be Save or Save As 
* Dropfiles on all Tabs are working 
* Songmarks will not disappear when you reload or restart the program 
* Improved the function when a directory will be selected 
* Save and Open in Trackmanager 
* A window for the alarm that can be placed anywhere 
* Larger fonts in the listboxes 
* Continue with fade function 
* Change background color when the alarm is overtime 
* Button to show more text or notes for a song 
* 12 hour clock 
* Change "M" to "¨" to select next song 
* Count down the song length 
* Toggle alarm count up and down 
* Updated GUI 
* Show MP3 information 
* Button to show the Square Identification window 
* Fixed a bug when the Square Identification window was showed the first time 
* Function to search the listbox for lyrics, tracking, marks and loops in Music Tab 
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6.23 
* Add choreography if followed by a reload 
* SDave volume for each song 
* Helpfile 
* Slowerbutton 
* CPU-usage can show highest value and an updated value 
* Updatetime for the GUI can be changed 
* Select if the listbox shall be for hoedown or singingcall 
* Squareidentification 
* Show what file or directory is selected in the choreography tabs 
* Drag and Drop files 
* Autofocus 
* Waittime between songs in Continue mode 
* Timern is counting all the time and is blinking after zero 
* Hide Card 
* SqRecord is included 
* EQ saved for each song 
* Start SD and SqRotation 
* Show file type and length 
* Find a call 
* Select more than one entry in the marklist 
* XP-Style 
* Definitions as a help-file 
* ColorPicker 
* Make the Progressbar clickable 
* Bitrate 
* Resetbutton 
* Show everything in minutes and seconds 
* Modeless Lyrics-ruta 
* Modeless Hotkey-ruta 
* Change all sliders 
 
6.00 
* Button for random selection of music 
* Mark played songs 
* Loop a fixed number of times 
* No startmeny 
* Options in main window 
* Save in all chorepgraphy tabs 
* Tool for make choreography lists 
* Play music in the playlist manager 
* Equalizer 
* Count down timer 
* Show lyrics in the music tab 
* Select a ini-file or a directory in the choreography tabs 
* Select if the title or label shall be shown in the first column 
* Split title and label in two columns in the lyric tab 
* More columns with information in the music tab 
* More functions in the song manager  
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Bass Error 
BASS_OK 0 all is OK 
BASS_ERROR_MEM 1 memory error 
BASS_ERROR_FILEOPEN 2 can't open the file 
BASS_ERROR_DRIVER 3 can't find a free/valid driver 
BASS_ERROR_BUFLOST 4 the sample buffer was lost 
BASS_ERROR_HANDLE 5 invalid handle. Check the file path. 
BASS_ERROR_FORMAT 6 unsupported sample format 
BASS_ERROR_POSITION 7 invalid playback position 
BASS_ERROR_INIT 8 BASS_Init has not been successfully called 
BASS_ERROR_START 9 BASS_Start has not been successfully called 
BASS_ERROR_ALREADY 14 already initialized/paused/whatever 
BASS_ERROR_NOPAUSE 16 not paused 
BASS_ERROR_NOCHAN 18 can't get a free channel 
BASS_ERROR_ILLTYPE 19 an illegal type was specified 
BASS_ERROR_ILLPARAM 20 an illegal parameter was specified 
BASS_ERROR_NO3D 21 no 3D support 
BASS_ERROR_NOEAX 22 no EAX support 
BASS_ERROR_DEVICE 23 illegal device number 
BASS_ERROR_NOPLAY 24 not playing 
BASS_ERROR_FREQ 25 illegal sample rate 
BASS_ERROR_NOTFILE 27 the stream is not a file stream 
BASS_ERROR_NOHW 29 no hardware voices available 
BASS_ERROR_EMPTY 31 the MOD music has no sequence data 
BASS_ERROR_NONET 32 no internet connection could be opened 
BASS_ERROR_CREATE 33 couldn't create the file 
BASS_ERROR_NOFX 34 effects are not available 
BASS_ERROR_PLAYING 35 the channel is playing 
BASS_ERROR_NOTAVAIL 37 requested data is not available 
BASS_ERROR_DECODE 38 the channel is a "decoding channel" 
BASS_ERROR_DX 39 a sufficient DirectX version is not installed 
BASS_ERROR_TIMEOUT 40 connection timed out 
BASS_ERROR_FILEFORM 41 unsupported file format 
BASS_ERROR_SPEAKER 42 unavailable speaker 
BASS_ERROR_VERSION 43 invalid BASS version (used by add-ons) 
BASS_ERROR_CODEC 44 codec is not available/supported 
BASS_ERROR_ENDED 45 the channel/file has ended 
BASS_ERROR_BUSY 46 the device is busy 
BASS_ERROR_UNSTREAMABLE 47 unstreamable file 
BASS_ERROR_UNKNOWN -1 some other mystery error 

 


